
Appendix B

Finite Element Analysis

Using NEi Nastran

B.1 INTRODUCTION

NEi Nastran is engineering analysis and simulation software developed by Noran Engi-

neering, Inc. NEi Nastran is a general purpose finite element analysis tool with an inte-

grated graphical user interface and model Editor which is used to analyze linear and

nonlinear stress, dynamics, and heat transfer characteristics of structures and mechanical

components. A complimentary copy of NEi Nastran student edition is included with this

book, which is composed of two modules: NEi Fusion and NEi Nastran. NEi Fusion com-

bines a finite element modeler, pre- and post-processing capabilities, and Nastran solvers

to create an analysis package for small and medium size problems. It is good for engi-

neers who need simulation for product development, virtual testing, design validation,

and quality assurance. Parts and assemblies can be analyzed for a spectrum of structural

and thermal loadings. In this chapter, we will present two tutorials using integrated

NEi Fusion/NEi Nastran software and several example problems in the text using

NEi Nastran alone.

B.2 GETTING START

To access NEi Fusion program on Windows systems, choose Start>All Programs>
NEi Fusion>NEi Fusion v1.2 (Note that the version number v1.2 may be different for

other versions). The startup screen will only show New and Open icons in the standard

toolbar. In order to see main windows, choose File>New in the main menu. Choose

Part and click OK in the New Document window. This command will open NEi Fusion

window as shown in Figure B.1. The NEi Fusion window is composed of different areas.

The graphic area shows geometries and finite elements as well as results of simulation.

The main menu contains primary NEi Fusion functions. The standard toolbars collects

commands that are frequently used. The Tab Menu on the left of the screen provides

model related functions. In order to finish NEi Fusion, choose File>Exit command.

NEi Fusion has its full documents as well as tutorials in help menu.

B.3 PLATE WITH A HOLE ANALYSIS

A. Introduction

This example problem illustrates the use of NEi Fusion/NEi Nastran for a simple static

analysis. You will learn how to build a solid model of a plate with a hole using NEi Fusion
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pre- and post-processor, perform the analysis with NEi Nastran, and examine the results

with NEi Fusion.

Figure B.2 shows a plate with a hole. The plate is fixed on the left edge and a uniform

pressure is applied on the right edge. The magnitude of pressure is chosen such that the

total applied force is 300 lb. The purpose of finite element analysis is to estimate the stress

concentration along the hole. Even if the model is three-dimensional solid, we will use

plane stress elements because stress along the thickness direction is negligible.

B. Creating the Part

1. Create a new part by selecting File> New in the main menu. Choose Part and

click OK in the New Document window.

2. Click Tools> Options. . . to open System Options window. Click Document
Properties tab and select Units on the left-hand side tree. Change the units to

IPS (inch, pound, second) in Unit system. Click OK to close Document Propert-

ies window.

Figure B.1 NEi Fusion main windows

Figure B.2 Plate with a hole model
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3. In the standard toolbar, select pull-down button of Sketch and choose Sketch in

the pull-down menu. Select Front plane in the graphic window as a sketch plane.

Note that the Front plane is x-y plane in the global coordinate system.

4. Draw a rectangle using rectangle icon in the toolbar. It is unnecessary to be a

precise dimension yet. Draw a circle inside the rectangle using circle icon in the

toolbar.

5. The vertical and horizontal line symbols on the rectangle

represent that these lines are either vertical or horizontal.

Choose the left vertical line (1) of the rectangle. On the

Tab menu area, Line Properties window will appear.

Change the starting coordinates to x¼�2 and y¼ 1 and

length¼ 2. Choose the top horizontal line (2) of the rectan-

gle. Change the starting coordinates to x¼�2 and y¼ 1

and length¼ 4. Now the rectangle is properly located.

6. Choose the circle and make its center locations (0, 0) and

radius 0.375.

7. Click Exit Sketch icon in the standard toolbar to leave

the sketch mode.

8. In the standard toolbar, select pull-down button of Fea-
ture and choose Extrude Boss/Base command.

9. In the Extrude window, change thickness¼ 0.25 in and

click OK button to generate a solid.
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10. Save the model by selecting File> Save menu. Provide ‘‘PlateHole.SLDPRT’’ as

the name of the part.

C. Pre-Processing the Model

Using the solid model that we created in the previous section, we will apply (1) material

properties, (2) physical properties, (3) boundary conditions, (4) external forces, and (5)

mesh the geometry. These steps are called pre-processing and will be done with the NEi -

Fusion program.

Switching to NEi Fusion

1. The NEi Fusion Modeler tab view looks as shown below. Choose the NEi Fusion

tab at the top of the tree view to switch to the NEi Fusion environment.

2. The NEi Fusion tree view looks as shown in the figure below.
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Select Materials

1. Right click on Materials in the entity list, and select New to create a new material.

2. In the Material window, type in Material1 in Name section.

3. Change the Young’s modulus E¼ 2.8E7 and Poisson’s ratio n ¼ 0:3. Leave shear

modulus G empty as it will be calculated using previous two constants.

4. Click OK (checkmark icon) to leave material section.

Apply the Constraints

1. We will create the mesh on the back face of the plate (This is the plane whose z-

coordinates are zero). Change the view to Hidden Line using the icon in the

standard toolbar.

2. Right-click on Constraints in the Entity List and select New.

3. In Constraints window, type in Constraint1 in Name section.

4. Select the left edge of the back face (1) as shown in the figure below. Click the

checkmark icon to add the constraint to the finite element model.

Apply the Load

1. The load is a 300 lbf force applied at the right edge of the plate in x-direction.

Right-click on Loads in the Entity List and select New.

2. In Load window, type in Load1 in Name section.

3. Select the right edge of the back face (2) as shown in the figure. Type in 300 in Fx
section. Click the checkmark icon to add the load to the finite element model.

Note that the constraint and load are defined before generating finite elements.
The nodal constraints and forces will be calculated when the model is meshed using
finite elements. If the loads and boundary conditions are defined in the solid model,
it is unnecessary to change them when different element sizes are used.

Automatic Mesh Generation

1. NEi Fusion can create mesh and update the boundary conditions (BC) automati-

cally with feature changes in the model.
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2. Right-click on Mesh in the entity list, and select Edit to define mesh parameters.

3. In Mesh window, type in 0.2 in Element Size (in) section. NEi Fusion will try to

make elements whose edges are close to 0.2 in.

4. Unselect the check mark in Solid Elements and select Shell Elements because

we are going to make plane elements.

5. Click rectangular box under Quadrilateral section, and select the back face of

the part in the graphic area. The rectangular box will now list Face <1>. This

means the back face will be meshed using quadrilateral elements. You may need

to rotate the part in order to select the back face. In the graphic window, hold the

middle mouse button and move the mouse around. You will see dynamic rotation

of the part.

6. Click the checkmark icon to add the mesh to the finite element model.

7. At the top of the entity list, right-click on Part1 and select Hide/Display Body.

This will turn off the solid model and only show finite elements.

Define Element Properties

1. Right-click on Physical Properties in the entity list and select New.

2. In the Physical Property form, type in PlaneStress1 for Name section; select

Shell Elements under Geometry Type; and type in 0.25 for Thickness.

3. Click the checkmark icon to add the physical property to the finite element model.

Setup the Analysis

1. In the entity list, right-click on Analysis 1 and select Edit.

2. In Analysis window, type in First try in the Name section and Plate with a hole
in the Title Section.

3. Click the checkmark to leave the analysis setup.

D. Running the Analysis

1. Right-click on the analysis name, First try and select Solve in NASTRAN.

2. This option allows the model to be run in a hidden mode; the default name of the

analysis input file would be the same as the saved part file name, PlateHole.NAS.
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In the hidden mode, the NEiNastran engine runs the model and displays the
progress in the NEiNastran Output window inside NEi Fusion Modeler. Depending
on the system, it may take a few minutes to run. Results are automatically loaded
into NEiFusion Modeler after the model is solved.

E. Post-Processing the Results

1. If you are in the NEi Nastran Output window, click on the Model tab at the bot-

tom of your screen to view the Model from the calculations.

After the solution is complete, NEi Fusion places four different contour plots

under Subcase 1 entity. The tree view looks as shown in the figure after the results are

loaded.

2. Right-click on the Contour on Deformed plot under Subcase 1 and select

Edit.

3. Select SHELL VON MISES in the Result Data of Contour Options. This will

plot the von Mises stress contour plot.

4. Type in 10 in Levels section.

5. Unselect Min/Max checkmark.

6. Click the checkmark icon at the top of the Plot window.

7. Right-click on the Contour on Deformed plot under Subcase 1 and select

Display. The von Mises stress contour plot is displayed on the deformed geome-

try, as shown in the figure. Compared to the nominal stress of 600 psi, the concen-

trated stress is about 1790 psi, which is consistent to the traditional stress

concentration factor of 3.
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8. In the main menu, select File> Save to save the model file.

9. In the main menu, select File>Exit to leave the NEi Fusion program.

This will end the tutorial.

B.4 STATIC ANALYSIS OF BEAMS1

A. Introduction

In this tutorial, we will learn how to perform a linear static analysis of a trailer model com-

posed of beams, as shown in Figure B.3. Through this analysis, the user will learn how to use

beam and bar elements in NEi Fusion/NEi Nastran. The units used in this analysis are IPS

(inches, pounds, and seconds). The effects of gravity are considered in this model.

B. Opening the Model

1. From the main menu select File>Open and open Tutorial 7.SLDPRT file locat-

ed in the ‘‘C:\Program Files\NEi Fusion\Application\Tutorial’’ folder.

1 Courtesy of Noran Engineering, Inc.

Figure B.3 A trailer model composed of beams
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2. Click File> Save As and save the part as ‘‘Tutorial 7 Trailer Frame.SLDPRT’’

in the working folder. This way the original part can be reused.

3. Switch to the NEi Fusion by clicking tab in the Tab menu.

C. Define Materials

1. Create a new material by loading AISI 304 Steel from the material library.

2. Right-click on Materials and choose New, then click on Load.

3. Browse to the location of the material library file, ‘‘C:\Program Files\NEi Fusion\
Application’’ and open the ‘‘solidworks materials.sldmat’’ file.

4. The material tree is populated with the available materials. Under the Steel cate-

gory, select AISI 304.

5. Delete the G value from the Structural properties field under the tree.

6. Click the checkmark icon to load the material.

D. Define Element Properties

1. In the tree view, right-click on Physical Properties and choose New.

2. Select Line Elements under Geometry Type.

3. The trailer frame is composed of structural members created using the NEi Fusion

Weldments Tools. By creating a line element property, you will be able to create

one-dimensional elements that have the physical properties based on the Structural

Member cross section and the material property. Se-

lect a structural member (1) on the model and click

on the NEXT arrow to create another structural

member physical property.

4. Repeat step 3 until all of the structural members

have been selected. Click the checkmark instead of the NEXT arrow to create

the final physical property. In total there should be 25 physical properties.
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E. Define Constraints

1. To make it easier to define the constraints and mesh the model, you will hide the

structural members. Switch to the Feature Manager Design Tree by clicking

in the Tab menu.

2. In order to hide structural members, it will be convenient to add the Hide feature to

the Structural Member right-click menu. To do this right click on a structural

member ‘‘Upper Frame’’ (it can be distinguished by the icon beside them) and

click on double arrows at the bottom to expand the full menu. Click on Customize
Menu.

3. Check the Hide option. Now the Hide feature will be shown to the Structural
Member right-click menu.

4. Right-click on a Structural Member in the tree and select Hide. Repeat for other

structural members until all are hidden. Now all structural members are displayed

as lines.

5. Switch to the NEi Fusion tab

6. In the tree view, right-click on Constraints and choose New.

7. Change the Name to Fixed Bars.

8. Select the lines (1) and (2) to fix as shown in the figure below.

9. Click the checkmark to create the fixed constraint.
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F. Define the Loads

1. Right-click on the Loads and choose New. Change the Name to Gravity Load.

2. Under Load, select Gravity for Type. Type in -386.4 in the Fy field under

Magnitude.

3. Click the checkmark to create the load.

G. Mesh the Model

1. Right-click on Mesh and choose Edit. Type 4 for

Element Size.

2. Uncheck the Solid Elements checkbox and check

the Beam/Bar Elements checkbox. Click on the

Lines/Arc box in the Beam/Bar Elements form so

that it is active.

3. Select all the sketch lines by clicking on the graphics

area and drag a box over the entire model. This will

select all the lines within the box to create the

Beam/Bar Elements.
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4. Click the checkmark to generate the mesh.

5. The mesh should look like the one shown below.

H. Add Entities to Model

1. Drag and drop constraint Fixed Bars, and load Gravity Load, one by one onto

Subcases.

2. Now the model looks like as shown in the image below.

NOTE: By selecting Subcase 1 when defining your loads and constraints, this section

could have been skipped.

I. Run the Analysis

1. Right click on Analysis 1 and select Solve in Nastran.
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J. Post-Process Results

1. The results are automatically loaded into NEi Fusion.

2. Right-click on Contour On Deformed under Subcase 1 and choose Edit.

3. Select BAR VON MISES STRESS for the Results Data under Contour Options.

Deselect the Max/Min checkbox.

4. Make sure Deformed and Contour are selected under Name. Click on Display.

Note the results.

5. Hide the sketches by switching to the Feature Manager Design Tree , and hid-

ing the sketches similar to how you hid the structural members. The results should

look like the image below.
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This concludes the tutorial. The major topics that were covered in this tutorial were

as follows:
� Running an analysis of a bar/beam structure
� Create line element physical properties based on existing structural elements created

with NEi Fusion Weldments Tools
� Using gravity loads

B.5 EXAMPLES IN THE TEXT

NEi Nastran Unser Interface

The finite element modeling and analysis can also be performed using NEi Nastran Edi-

tor. The NEi Nastran Editor is a utility that allows the user to manage analysis files, moni-

tor analysis progress, queue multiple analysis jobs, change NEi Nastran settings and

options, and access the NEi Nastran help file. NEiNastran Editor can be launched from

Start> All Programs> NEi Nastran> NEi Nastran Editor in Windows system.

In the large Editor View of the NEi Nastran Editor (see Fig. B.4) you should see the

Errors/Warnings View. In this view you will see a listing of any errors and warnings

generated during the analysis. You can see more information by selecting from the sever-

al tabs at the bottom of the Editor View.

Click the Nastran tab and you will see the Model Input File. This is the file that

NEi Fusion prepares when you choose Solve in Nastran command. It contains all of the

pre-processed model data needed by the NEi Nastran solver to perform the analysis.

The Analysis View shows the status information provided by the solver during the

analysis.

Figure B.4 NEi Nastran Editor window
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Click the Result Summary tab and the Result Summary File appears in the view.

The Results Summary File is a report of any runtime errors or warnings, the model’s

properties, the number of elements, number of degrees of freedom, maximum aspect ra-

tios of the elements, total mass, epsilon, strain energy, extreme values of various stresses,

and other data. The report’s contents can be interrogated or printed from the Editor.

The Output View has the listing of the output file that is written by NEi Nastran when

the analysis is complete. This file contains all of the analysis results in an ASCII format.

To the left of the Editor View is the Options View. Here the Model Initialization File

settings can be viewed or modified. These settings allow you to configure NEi Nastran.

The window on the bottom is the Messages Window. The messages displayed here

come from the NEi Nastran Editor and solver.

NEi Nastran Model Input File Format

The first step in performing analysis using NEi Nastran is to generate the Model Input

File, which defines the geometry, material properties, boundary conditions, and applied

loads. The Model Input File is an 80 column ASCII text file and can be created using

NEi Nastran Editor or any text editors. The Model Input file also specifies analysis proce-

dures as well as outputs. The Model Input file is divided into two distinct sections: the

Case Control Section and the Bulk Data Section. Input in the Case Control Section is

referred to as a command and in the Bulk Data Section as an entry. The Case Control

section must appear first, followed by Bulk Data section.

The Case Control Section begins with the first command and ends with the com-

mand, BEGIN BULK. It defines the subcase structure for the problem, makes selections

from the Bulk Data Section, defines the output coordinate system for element and grid

point results, and makes output requests for the Model Results Output File.

The Bulk Data section begins with the entry following BEGIN BULK and ends with

the entry ENDDATA. It contains all of the details of the structural model and the condi-

tions for the solution. BEGIN BULK and ENDDATA must be present even though no

new bulk data is being introduced into the problem or all of the bulk data is coming from

an alternate source, such as user-generated input. The format of the BEGIN BULK entry

is either a free field or a structured field. Data are separated by comma in free field, while

each data is written within eight columns in structured field.

Plane Truss Example 1

In this section, the two–bar truss in Example 2.4 is solved using NEi Nastran Editor. The

problem we are analyzing is shown in Figure 2.11 in Chapter 2 and the corresponding

NEi Nastran Model Input File is shown in Table B.1. The Case Control section has five

commands. The first command ‘‘SOL LINEAR STATIC’’ specifies that the linear static

analysis will be employed. Next two commands request for outputs. In this case, displace-

ments of all nodes and stresses of all elements will be included. Also these data will be

available in the output file as well as database.

The next ‘‘SPC¼1’’ command directs NEi Nastran to apply constraints defined by

the SPC entry with an identification number (ID) of 1 in the Bulk Data Section. The

‘‘LOAD¼1’’ command directs NEi Nastran to apply loading defined by the FORCE entry

with an ID of 1 in the Bulk Data Section.

The start of the Bulk Data Section is denoted by the BEGIN BULK delimiter and the

end, the ENDDATA delimiter. Both are delimiters are required. The model’s geometry is

defined via the GRID entry, which corresponds to node. Each grid point coordinate is

defined in the default basic coordinate system. The format for GRID entry is:
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GRID ID CP X Y Z CD

ID is non-overlapping node number, CP¼ 0 for the default basic coordinate system,

and (X, Y, Z) is the coordinates of the node, and CD is the displacement coordinate

system.

Element connectivity is defined via the CBAR entries. The format of CBAR entry is:

CBAR EID PID GA GB X1 X2 X3

EID is the element identification number, PID is property identification number of

PBAR, GA and GB are two grid points, and (X1, X2, X3) are vector that defines the local

x-y plane in the displacement coordinate system.

The properties of BAR element are defined using PBAR entry. The format of PBAR

entry is:

PBAR PID MID A I1 I2 J NSM

PID is the property identification number, MID is the material identification number,

A is the cross-sectional area, I1 and I2 are area moment of inertia, J is the torsional con-

stant, and NSM is nonstructural mass per unit length.

The material property of the BAR element is defined using MAT1 entry, which de-

fines the material properties of linear, temperature-independent, isotropic materials. The

format of MAT1 entry is:

MAT1 MID E G NU RHO A TREF GE

MID is the material identification number, E the Young’s modulus, G the shear mod-

ulus, NU Poisson’s ratio, RHO the density, A the thermal expansion coefficient, TREF the

reference temperature, and GE structural damping coefficient.

Table B.1 NASTRAN Commands for Plane Truss Example 1

SOL LINEAR STATIC
DISPLACEMENT(PRINT,PLOT) = ALL
STRESS(PRINT,PLOT,CORNER) = ALL
SPC = 1
LOAD = 1
BEGIN BULK
GRID 1 0 0. 0. 0. 0
GRID 2 0 12. 8. 0. 0
GRID 3 0 12. 0. 0. 0
CBAR 1 1 1 2 1. 0. 0.
CBAR 2 1 2 3 1. 0. 0.
PBAR 1 10.04908 7 0. 0. 0. 0.
MAT1 1 3.E+7 0. 0. 0.
FORCE 1 2 0 1. 50. 0. 0.
SPC 1 1 123456 0.
SPC 1 3 123456 0.
ENDDATA
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The applied load can be specified using FORCE entry. The format of FORCE entry is:

FORCE SID G CID F N1 N2 N3

SID is the load set identification number, G the grid point that the force is applied,

CID the coordinate system, F the load scale factor, (N1, N2, N3) is the vector of load in

CID coordinate system.

The displacement boundary conditions are applied using two SPC entries. The format

of SPC entry is:

SPC SID G1 C1 D1 G2 C2 D2

SID is the identification number of single point constraint set, G1 and G2 are Grid

points, C1 and C2 are component numbers of global coordinates, and D1 and D2 are

enforced displacements. For example, when all six DOFs are fixed, C1 and C2 have the

value of 123456.

Once, the Model Input File is prepared, finite element analysis can be performed by

selecting Analysis>Run command or simply clicking F5 key. Analysis progress will be

shown in Analysis window. Once the analysis is finished, Errors/Warnings window will

show ant errors or warnings that occur during analysis.

The Output window shows analysis results. There is a quite amount of information in

the output. By scrolling down the output window, we can find the nodal displacement and

element stress. Since Nodes 1 and 3 are fixed, their displacements will be zero. Node 2 is

the only free node, whose displacement is

GRID T1 T2 T3 R1 R2 R3

2 8.28E-4 �1.81E-4 0.0 0.0 0.0 0.0

Note that T1, T2, and T3 are displacements in X, Y, and Z-coordinates, respectively,

and R1, R2, and R3 are rotations.

The axial stresses of two elements can also be found in the Output window.

Element E1 E2

Axial Stress 1.22E+3 �6.79E+2

Plane Truss Example 2

In this section, a nine-bar truss in Figure B.5 is solved using NEi Nastran Editor. The

corresponding NEi Nastran Model Input File is shown in Table B.2. The Case Control

section is identical to that of the two-bar truss example.

In the Bulk Data section, the model has six GRID entries, nine CBAR entries. But,

their definitions are similar to that of the previous example. We used Young’s modulus of

E¼ 2.9�107 psi. Since 1,200 lb force is applied in the negative y-axis at Node 3, the

FORCE entry has �1200 for N2 column. Also, 400 lb force is applied in N1 column of

Node 6. Since Node 1 is fixed, all six DOFs are constrained, while Node 4 is allowed to

move in the x-coordinate direction.
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After finishing finite element analysis, the displacements and stresses of the model

can be found in the Output window. However, NEi Nastran Editor provides graphical

post-processing capability.

Select Model/Results window. In the Options window (left to the main screen),

Results> NEiNastran>Vector Results> Total Translation. This command will produce a

contour plot of displacement. In the Toolbar, click ‘‘Display Contour’’ icon and ‘‘Display

Deformed View’’ icon. The main window now shows the deformed geometry of the

model, as shown in Figure B.6.

Portal Frame Analysis

Consider the plan frame in Figure B.7. All frames have the same material properties.

The horizontal frame has different cross-sectional geometry from two vertical frames.

All frames are made of the same material with Young’s modulus E¼ 210 GPa. Two

vertical frames have area A1 ¼ A2 ¼ 4:53� 10�3 m2 and moment of inertia

Figure B.5 Nine-bar truss model

Table B.2 NASTRAN Commands for Plane Truss Example 2

SOL LINEAR STATIC
DISPLACEMENT(PRINT,PLOT) = ALL
STRESS(PRINT,PLOT,CORNER) = ALL
SPC = 1
LOAD = 1
BEGIN BULK
GRID 1 0 0. 0. 0. 0
GRID 2 0 144. 0. 0. 0
GRID 3 0 288. 0. 0. 0
GRID 4 0 432. 0. 0. 0
GRID 5 0 144. 108. 0. 0
GRID 6 0 288. 108. 0. 0
CBAR 1 1 1 2 0. 1. 0.
CBAR 2 1 2 3 0. 1. 0.
CBAR 3 1 3 4 0. 1. 0.
CBAR 4 1 1 5 0. 1. 0.
CBAR 5 1 2 5 1. 0. 0.
CBAR 6 1 3 5 0. 1. 0.
CBAR 7 1 5 6 0. 1. 0.
CBAR 8 1 3 6 1. 0. 0.
CBAR 9 1 4 6 0. 1. 0.
PBAR 1 1 3.14159 0. 0. 0. 0.
MAT1 1 2.9E+7
FORCE 1 3 0 1. 0. -1200. 0.
FORCE 1 6 0 1. 400. 0. 0.
SPC 1 1 123456 0.
SPC 1 4 23456 0.
ENDDATA
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I1 ¼ I2 ¼ 2:51� 10�5 m4. The horizontal frame has area A3 ¼ 1:43� 10�2 m2 and mo-

ment of inertia I3 ¼ 3:309� 10�4 m4. Uniformly distributed load p ¼ 75 kN=m is ap-

plied at the horizontal frame, and a concentrated force F ¼ 1 kN is applied in the

horizontal direction at Node 2.

The NEi Nastran commands for the portal frame example are shown in Table B.3.

Note that FORCE command is added in the CASE Control section, which will print ele-

ment forces (bending moment, shear force, and axial force). In the Bulk Data section, the

same CBAR elements are used for the frame elements. In fact, CBAR can be used for

truss, beam and frame elements. In PBAR entry, not only for the cross-sectional area, but

also the moment of inertia column is provided because the element will behave like the

combined uniaxial bar and beam element. In addition to the FORCE entry, PLOAD1

entry is provided, which defines distributed loads to CBAR elements at user chosen points

along the axis. The format of PLOAD1 entry is:

PLOAD1 SID EID TYPE SCALE X1 P1 X2 P2

Figure B.7 Plane frame structure under distributed and concentrated load

Figure B.6 Displacement contour plot of nine-bar truss
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SID and EID are load set and element identification numbers, respectively; TYPE is

the type of distributed load (FX, FY, FZ, FXE, FYE, FZE, MX, MY, MZ, MXE, MYE,

MZE); SCALE is the scale factor; X1 and X2 are locations starting from the first node;

and P1 and P2 are load factors at location X1 and X2, respectively. If SCALE¼ FR (frac-

tional), the Xi values are ratios of the distance along the axis to the total length, and (if X2

6¼ X1) Pi are load intensities per unit length of the element.

The analysis procedure is identical to the previous examples. In the Output window,

we can find the bending moment, shear force, and axial force of each element, as shown

in Table B.4.

Table B.4 Bending Moment, Shear Force, and Axial Force of the Portal Frame

Element Node Bending moment Shear force Axial force

1 1 �1.980678Eþ04 �1.512745Eþ04 �2.246731Eþ05

2 4.070301Eþ04 �1.512745Eþ04 �2.246731Eþ05

2 3 �4.266460Eþ04 �1.612745Eþ04 �2.253269Eþ05

4 2.184518Eþ04 �1.612745Eþ04 �2.253269Eþ05

3 2 �4.070301Eþ04 �2.246731Eþ05 �1.612745Eþ04

3 �4.266460Eþ04 �2.246731Eþ05 �1.612745Eþ04

Table B.3 NASTRAN Commands for Portal Frame

SOL LINEAR STATIC
DISPLACEMENT(PRINT,PLOT) = ALL
STRESS(PRINT,PLOT,CORNER) = ALL
FORCE(PRINT,PLOT,CORNER) = ALL
SPC = 1
LOAD = 1
BEGIN BULK
GRID 1 0 0. 0. 0. 0
GRID 2 0 0. 4. 0. 0
GRID 3 0 6. 4. 0. 0
GRID 4 0 6. 0. 0. 0
CBAR 1 1 1 2 1. 0. 0.
CBAR 2 1 3 4 1. 0. 0.
CBAR 3 2 2 3 0. 1. 0.
PBAR 1 1 0.00453 2.51E-5 0. 0. 0.
PBAR 2 1 0.0143 3.309E-4 0. 0. 0.
MAT1 1 2.1E+11
FORCE 1 2 0 1. 1000. 0. 0.
PLOAD1 1 3 FYE FR 0. -75000. 1. -75000.
SPC 1 1 123456 0.
SPC 1 4 123456 0.
ENDDATA
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