
Appendix A

Finite Element Analysis Using

Pro/Engineer

A.1 INTRODUCTION

Pro/ENGINEER is a three-dimensional product design tool that promotes practices in de-

sign while ensuring compliance with industry and company standards. Integrated, para-

metric, three-dimensional CAD/CAM/CAE solutions allow engineers to design products

fast, while improving innovation and quality to ultimately create exceptional products.

Although the main function of Pro/ENGINEER is a solid modeler, it also provides vari-

ous engineering analyses tools such as kinematic analysis, structural and thermal analysis.

In this chapter, we will introduce structural finite element modeling and analysis using

Pro/ENGINEER Mechanica, which is a CAE (Computer Aided Engineering) tool that

enables engineers to simulate the physical behavior of a model and to understand and

improve the mechanical performance of the design. It can directly calculate stresses, de-

flections, frequencies, heat transfer paths, and other factors, showing how the model will

behave in a test laboratory or in the real world.

The Pro/ENGINEER Mechanica product line features two modules—Structure and

Thermal—each of which solves for a different family of mechanical behaviors. Structure

focuses on the structural integrity of the model, while Thermal evaluates heat-transfer

characteristics.

Mechanica is available in two basic modes—integrated mode and independent mode. In

integrated mode, engineers perform all Mechanica functions within Pro/ENGINEER environ-

ment. This version of the product offers the convenience and power of Pro/ENGINEER’s

parametric feature-creation technology coupled with the full range of Mechanica’s solution

software. However, some specific capabilities of Mechanica cannot be used in the integrated

mode. In independent mode, engineers work in a separate user interface, developing the model

from imported geometry or geometry that is created using Mechanica’s geometry-creation

facilities. In this Chapter we will use the integrated mode in performing finite element analysis.

A.2 GETTING START

To access Pro/Engineer program on Windows systems, choose Start >All
Programs>PTC>Pro Engineer>Pro Engineer. This command will open Pro/

Engineer window as shown in Figure A.1. The Pro/Engineer window is composed of differ-

ent areas. The drawing area shows part geometry and finite elements as well as results of

simulation. Once a part is created, the Navigation window will show part tree. Under the

main menu, various toolbars are shown, which collect frequently used commands. Since no

part is created, most commands are inactive. Usable commands will be activated depending

on the current status of the model. In addition, locations of toolbars can be moved.
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In order to finish Pro/Engineer, choose File >Exit command. Then, Confirmation
window will show up. Choose Yes to finish the program.

Pro/Engineer has its full documents in help menu. In the main menu, choose Help >
Help Center. Then Pro/Engineer Help windows will show up. In this documentation, the

user can find all manuals and tutorials available in Pro/Engineer.

A.3 PLATE WITH A HOLE ANALYSIS

A. Introduction

This example problem illustrates the use of Pro/Engineer for a simple static analysis. You

will learn how to build a solid model of a plate with a hole, to create finite elements, to

perform the analysis, and to examine the results suing Pro/Engineer.

Figure A.2 shows a plate with a hole. The plate is fixed on the left edge and a uniform

pressure is applied on the right edge. The magnitude of pressure is chosen such that the

total applied force is 300 lb. The purpose of finite element analysis is to estimate the stress

concentration along the hole. Even if the model is three-dimensional solid, we will use

plane stress elements because stress along the thickness direction is negligible.

B. Creating the Part

In this section, a simple plate with a hole is constructed using Pro/Engineer solid model.

This model will be used for finite element analysis.

1. Start Pro/Engineer and change working folder

File> Set Working Directory
Select or create a directory in which a part will be created. Note Pro/Engineer

use the term ‘‘directory’’ which is identical to ‘‘folder’’ in windows system.

Figure A.1 Layout of Pro/Engineer main window
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2. Create a new part

File>New>Part> part name ‘‘PlaneStress’’

3. Set up a unit to inch (pound f)

Edit> Set up>Unit> Inch Pound Second (IPS)> Set>OK (Changing mod-
el unit)>Close (Unit Manager)>Done (Menu manager)

4. Specify part creation method

Insert>Extrude>Placement (in the message area)>Define
We will sketch the section of the part and extrude it to make a solid. This is

the most common way of creating a part. Sketch window will appear

5. Select Sketch Plane

In the drawing area, three datum planes and a coordinate system are shown.

Select the FRONT plane and click Sketch button in the Sketch window.

The viewpoint is changed such that the FRONT plane is the sketch plane.

The sketch menu appears on the right side of the main window.

6. Create 400 � 200 rectangular section

Select Sketch>Rectangle and pick the origin of the coordinate system and

pick another point in the drawing area to create a rectangle. The size of the rectan-

gle is not important yet. Click the middle mouse button finish creating the rect-

angle. The same action can be done by selecting rectangle symbol in the toolbar

on the right side of the drawing area. Now the size of the rectangle will be shown

as dimensions.

Double click each dimension text and change their values so that the size of

rectangle be 400 � 200 as shown in the figure below. You can move the dimension

texts by dragging them in the drawing area.

Figure A.2 Plate with a hole model
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7. Create � 0.75 circle at the center of the rectangle.

Select circle icon on the right side toolbar. Select the center location close to

the center of the rectangle and click another point to define the circle. Click the

middle mouse button to finish creating the circle. Change dimensions in the cir-

cle so that the location is in the center of the rectangle and its diameter is 0.75 in.

Now the section should look like the figure below.

8. Finish creating the section

Click the checkmark (continue with the current section) on the right toolbar

to finish creating the section. The drawing toolbars on the right will disappear.

9. Extrude the section to create a solid

In the message window (below the placement button), type in 0.25 for the

depth value; click extrude direction so that the part is extruded in backward; and

click checkmark to extrude the section by 0.25 in.
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10. Save the solid model and exit

File> Save> file name ‘‘PLANESTRESS.PRT’’
File>Exit>Yes

Check whether file ‘‘planestress.prt.1’’ in your working folder exists.

C. Finite Element Analysis (Integrated Mode)

In the integrated mode, the finite element analysis is performed within Pro/Engineer envi-

ronment. In the integrate mode, the Mechanica is considered as a sub-menu system of

Pro/Engineer.

1. Start Pro/Engineer, change the working directory, and open file ‘‘planestress.prt’’

File> Set Working Directory
File>Open> planestress.prt

2. Start Mechanica Application

Application>Mechanica>Continue> Structure>OK

3. Idealization

Insert>Midsurface>New>Constant> Select top surface>Hold control-
key and select bottom surface>OK>Done/Return

Finite element model does not have to be exactly the same as the solid model,

as long as its mathematical behavior is same. Idealization simplifies the solid

model to a plate because displacement and stress are constant through the thick-

ness. In order to see the created mid-surface,

Insert>Midsurface>Compress> Shell & Solid>Done>Done/Return>
Done/Return

We are creating plane stress element with the thickness the same as the solid

4. Displacement boundary condition

Insert>Displacement constraints
In the Constraint window, type in displBC for Name, choose Edge(s)/

Curve(s) for Reference and select Edge (1) in the figure below. Select OK to

close the Constraint window.

ConstraintSet1 is the name of default set that can include multiple displace-

ment BCs.

5. Applied load

Insert>Force/Moment Load
In the Force/Moment Load window, type in Traction for Name, choose

Edge(s)/Curve(s) for Reference and select Edge (2) in the figure below. Type in

X¼ 300 in force column. Select OK to close the Force/Moment Load window.

LoadSet1 is the name of default set that can include multiple loads.
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6. Material Data

Properties>Materials
In Material window, choose STEEL and click triple arrow to add the mate-

rial to the model. Click OK to close the Material window.

Assign the material to the part by clicking Properties>Material Assignment>
OK. Since PlaneStress is only part and STEEL is only material, we accept defaults.

7. Create Analyses

Analyses>Mechanica Analyses/Studies. . .
In Analyses and Design Studies window, select File>New Static

In Static Analysis Definition window, type in ‘‘PlaneStress’’ for Name,

highlight ‘‘ConstraintSet1’’ and ‘‘LoadSet1’’. Select Multi-pass adaptive with

Polynomial Order, Minimum¼ 1, Maximum¼ 9, and Percent convergence ¼
5% ! OK! Close

In pro/Mechanica, the order of interpolation is increased progressively until the solu-

tion converges.

8. Run the simulation

In Analyses and Design Studies window, select ‘‘PlaneStress’’ in the box and

click Run study icon. The finite element analysis will start in background. The

status of analysis can be found by clicking Simulation status icon.

9. Post-processing (Stress contour plot)

Once the analysis is finished, the analysis results can be plotted by clicking

Display results icon. Result Window Definition windows will appear. The de-

fault values in the window plot the von Mises stress contour. Click OK and Show
to plot with default values.
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10. Post-processing (Convergence graph)

In addition to the stress contour plot, it is possible to plot a convergence graph

of strain energy. Before creating the graph, close the stress contour window by

choosing File>Exit Results>No
In the Analysis and Design Studies window, choose Display results icon

again. Result Window Definition window will appear. Select Graph for Display

type and Measure for Quantity. Click the Measure icon below Measure, and se-

lect Strain energy when the Measure window appears. Select OK to close the

Measure window and OK and Show to display the graph.

The graph shows that the strain energy of the model converges to 0.0148 as

higher-order polynomials are used for elements.

Close the convergence graph by selecting File>Exit Results>No

A.4 DESIGN SENSITIVITY ANALYSIS/
PARAMETER STUDY

One of the powerful capabilities in finite element analysis is to easily change the design

parameters and to perform what-if study without building the actual part. The purpose of

this section is to identify how the performance of the model changes according to the

design parameters.

1. Design Sensitivity Study Definition

Select Analysis>Mechanica Analysis/Studies from the main menu. In the

Analysis and Design Studies window, select File>New Sensitivity Design
Study. Sensitivity Study Definition windows will appear. Type in Sensitivity

Analysis for Name and select PlaneStress in Analysis section.

2. Design Variables

In the same window, click Select dimension from model icon and select the

part. Then, dimensions of the part will appear. Select height dimension of the

plate. Change the name of the variable to ‘‘Height’’. Change the start and end

value of the height dimension to 1.85 and 3.0, respectively.

Select the diameter dimension using the same way and provide 0.5 for start

and 0.9 for end. Change the name of the variable to ‘‘Diameter’’. Click OK to

close Sensitivity Study Definition window.
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3. Run sensitivity analysis

In Analysis and Design Studies window, click Start Run icon to run sensitiv-

ity analysis.

4. Review sensitivity results

When analysis is finished, choose Review Results icon in the Analysis and

Design Study window.

In the Result Window Definition window, type in ‘‘Sensitivity w.r.t. Height’’

in Title. Note that SensitivityAnalysis and PlaneStress are chosen by default in

Design Study section. Click Measure icon below Measure section and choose

max_stress_vm in the Measure window. Click OK to close it. Select Height de-

sign variable (or d1) in the Graph Location section and click OK and Show but-

ton to plot the parameter study results.
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Note that the von Mises stress decreases as the height of the plate increases. A

similar graph can be plotted for the diameter design variable.

A.5 DESIGN OPTIMIZATION

Design optimization is automatic design process to find what would be the best design

given limitations and conditions. First, we have to define what the goal (measure) is and

what the constraints (measure) are. Also, the design parameters need to have the lower

and upper bounds that the engineer wants to change. All designs that are covered by the

lower and upper bounds are called the design domain. Then, the optimization program

sequentially changes the design parameters and finds the design that can minimize (or

maximize) the goal while satisfying all constraints within the design domain.

1. Optimization Study Definition

Select Analysis>Mechanica Analysis/Studies from the main menu. In the

Analysis and Design Studies window, select File>New Optimization Design
Study. Optimization Study Definition windows will appear. Type in ‘‘Optimiza-

tion’’ for Name.

2. Define optimization problem

Note that minimize total_mass is chosen for the goal by default.

We want to limit the maximum von Mises stress less than 2500 lbf/in2. In

order to do that, click Measure icon on the right side of Design Limits section,

and choose max_stress_vm in the Measure window. Type in ‘‘2500’’ in Value

column so that the design limit looks like max_stress_vm < 2500.

By following the same procedure in the sensitivity study, define two design

variables (height and diameter). For diameter, use minimum (0.5), initial (0.75),

and maximum (0.9). For height, use minimum (1.85), initial (2), and maximum (3).
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3. Launch the optimization program

In Analysis and Design Studies window, click Start Run icon to run sensitiv-

ity analysis.

4. Plot the design history

When analysis is finished, choose Review Results icon in the Analysis and

Design Study window.

In Result Window Definition window, type in ‘‘Optimization’’ for Name.

Note that Optimization and PlaneStress are already chosen for Design Study and

Analysis, respectively. Select Graph in the Display type section and Measure in

the Quantity section. Using the Measure icon below Measure, choose total_mass

as the quantity of plot. Click OK and Show to plot the history of the total mass.

In order to insert maximum stress history, choose Insert>Result window
from the main menu. Result Window Definition window will appear. Type in

‘‘History2’’ for Name and choose Optimization in Design Study section. Note

that PlaneStress will be automatically added in Analysis because it is the only

analysis in Optimization. Choose Graph in the Display type section and Measure
in the Quantity section. Using the Measure icon below Measure, choose max_

stress_vm as the quantity of plot. Click OK and Show to plot the history of the

total mass.

In the history figure, the goal (total mass) is reduced significantly at the first design

cycle. However, as can be found in the stress history, the new design slightly violates the

stress constraints (it is greater than 2500 psi!). Thus, the optimization program slightly

modifies the designs twice so that the total mass cannot be reduce further without violat-

ing the stress constraint, which is by definition an optimum design.
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